RMA time for me

Chat about Hammerhead's Karoo in general.
Post Reply
User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

RMA time for me

Post by Steve » Tue Jun 26, 2018 1:33 pm

Looks like my Karoo is faulty. A while back my elevation figures started getting more and more crazy (e.g. over 100,000 ft of climbing), and for the past several rides the elevation has been blank (even after manually calibrating, factory resetting, etc). Also my temperature field is blank.

HH are arranging a replacement unit for me.

dthempel
Site Admin
Posts: 240
Joined: Tue Mar 06, 2018 3:35 pm
Location: Cape Cod, MA
Contact:

Re: RMA time for me

Post by dthempel » Tue Jun 26, 2018 5:49 pm

Here's hoping you get a good/better one not the lemon yours turned into...

JohnJ80
Posts: 184
Joined: Tue Apr 03, 2018 4:55 pm

Re: RMA time for me

Post by JohnJ80 » Tue Jun 26, 2018 8:49 pm

Be interesting to hear if there are differences. Presumably, you will receive a currently manufactured device.

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Tue Jun 26, 2018 8:52 pm

Thanks. I'm wondering if I'll get someone's returned unit, or a new one. And if it's a new one, will it have a new foot?

JohnJ80
Posts: 184
Joined: Tue Apr 03, 2018 4:55 pm

Re: RMA time for me

Post by JohnJ80 » Tue Jun 26, 2018 9:03 pm

Be interesting to hear if there are differences. Presumably, you will receive a currently manufactured device.

dthempel
Site Admin
Posts: 240
Joined: Tue Mar 06, 2018 3:35 pm
Location: Cape Cod, MA
Contact:

Re: RMA time for me

Post by dthempel » Wed Jun 27, 2018 1:54 pm

JohnJ80 wrote:
Tue Jun 26, 2018 9:03 pm
Be interesting to hear if there are differences. Presumably, you will receive a currently manufactured device.
There's no indication that they're on "rev 2" of the hardware other than the foot. Also, without cracking it open, how would we know? :)

Steve Donovan
Posts: 26
Joined: Thu Mar 29, 2018 12:01 pm
Location: Yorkshire, UK

Re: RMA time for me

Post by Steve Donovan » Wed Jul 11, 2018 1:25 pm

Steve, have they said how long your replacement unit is likely to take to arrive ?

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Wed Jul 11, 2018 7:00 pm

Steve Donovan wrote:
Wed Jul 11, 2018 1:25 pm
Steve, have they said how long your replacement unit is likely to take to arrive ?
They won't send the replacement unit until they get the faulty unit back. I'm in the UK but luckily mine only needs to go to their depot in The Netherlands.

I sent mine last Thursday and I expected it to get to The Netherlands around Tuesday, but today the tracking isn't showing me anything other than it having left the UK. Which was disappointing.

However, I have had an email telling me that I'm getting a delivery from DPD tomorrow. HH use DPD. I can't remember anything else that I'm expecting, so I've got my fingers crossed that it's the replacement Karoo, and my tracking info just hasn't been updated.

nordog
Posts: 163
Joined: Thu Mar 08, 2018 7:32 pm

Re: RMA time for me

Post by nordog » Wed Jul 11, 2018 11:51 pm

Good luck in getting the new one tomorrow and it works OK for the weekend. Mine will be Ok on The GWR ride of just 75 miles Ashton to Weston.

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Thu Jul 12, 2018 1:06 pm

Thanks, nordog.

Unfortunately today's delivery wasn't a Karoo, it was a non-cycling-related Kickstarter reward from ages ago that I hadn't realised was being shipped out.

The good news is that today my tracking info seems to have woken up, and I saw that my defective Karoo arrived at HH's depot in The Netherlands today. So I contacted HH via my support ticket and told them. They have told me that "The warehouse would take 2-3 days to process this unit and send out the replacement". Which is a little disappointing in terms of service speed.

The wait goes on.

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Thu Jul 12, 2018 3:34 pm

When I queried whether this 2-3 days was the "expedited" service that Ali had promised me, when I previously queried why they need to wait for my unit back and how long this was going to take, they told me that "The warehouse usually takes 5-6 days. Ali had already informed the warehouse about your order and so it will be expedited within the next 2-3 days to process your unit and send out the replacement".

Just informing others about timescales should you find yourselves in the same boat.

nordog
Posts: 163
Joined: Thu Mar 08, 2018 7:32 pm

Re: RMA time for me

Post by nordog » Thu Jul 12, 2018 10:12 pm

Could be the staff is either quick or slow Monday or Friday etc. :?:

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Mon Jul 16, 2018 7:29 am

Last night I received automated emails telling me that my exchange had been authorised and confirmation of the"order" for a replacement unit. Now waiting for shipping confirmation.

Edit - just received shipping confirmation and a tracking number. So hopefully it'll be here shortly.

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Thu Jul 19, 2018 10:18 am

It's here at last! Pleased to see that they do ship these with a new foot too. Now to find some time to get it set up. Should be able to try it out this Sunday for a ride.

IMG_20180719_111006a.jpg
IMG_20180719_111006a.jpg (450.47 KiB) Viewed 810 times

User avatar
Steve
Site Admin
Posts: 470
Joined: Tue Mar 06, 2018 2:56 pm
Location: Surrey, UK

Re: RMA time for me

Post by Steve » Mon Jul 23, 2018 9:09 am

Wow. I had the best ride yet with my replacement Karoo. My elevation measurement worked perfectly (well, as "perfectly" as this sort of device can - measuring elevation is always a tricky thing) and displayed a nice graph for me. My temperature measurement actually worked for a change too (my old temp sensor was obviously broken), and seemed about right.

My speed/distance/etc all seemed about right. The new, much more granular countdown to turns was a very welcome improvement, although the font could do with being a bit bigger for me without having reading glasses on - it seems smaller than it used to be, but I could be mistaken. Navigation also worked well.

Battery usage wasn't great, but at the moment I'm prepared to put that down to this being the very first use of my Karoo on a ride, so the battery might need a couple of charge/discharge cycles to get fully up to capacity.

Very pleased with my replacement Karoo, and it makes me wonder how many other issues that I saw on the original one were down to dodgy hardware.

nordog
Posts: 163
Joined: Thu Mar 08, 2018 7:32 pm

Re: RMA time for me

Post by nordog » Mon Jul 23, 2018 9:59 am

Very glad you now have your new Karoo & up & running to good effect Steve.
I also found the text to small to read with my Oakley cycling sunglasses on last weekend, lucky for me the route was well signed.

SteveKao
Posts: 1
Joined: Thu Jul 26, 2018 5:06 pm

Re: RMA time for me

Post by SteveKao » Thu Jul 26, 2018 5:09 pm

Good to hear Steve. I am in the same exact boat with my barometer/temp sensor being faulty. Hammerhead issued an RMA and I just sent my faulty device back today.

Post Reply